ネットワークエンジニアで高きを目指せ(市ヶ谷編)

IT修行中(マレーシア<ー>ベトナム⇒日本)

:月額1000円、動画の量が豊富なのが魅力。どんなにプログラミングのモチベーションが下がっても戻ってこれるのはドットインストールのおかげ。

作る楽しみはここが教えてくれる!

月額料金980円オブジェクト、クラス、メソッド等基本的なことを学べる。おそらく多くのエンジニア志望者はこれから始めると思われる。
:月額1078円とても詳しく説明してくれるがJavascriptを学ぶ講座は少ない。ドットインストール、Progateに続いてやっていいサイトだと思う。

■□━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━□■

SEO対策からビジネス相談まで!500円から買えるココナラ

■□━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━□■

テレビや新聞、雑誌で注目のココナラ! SEO対策、ビジネス相談、キャリア相談など、登録料は無料で、全て500円~で お願いできる!

価格満足度97%、まだ知らないあなたは損しているかも? あらゆるお困りごとはココナラにお任せ!

https://coconala.com/

   

↓↓↓こちら私の招待コードです。こちらから登録すれば300Pointゲット(300円分)

 

ご招待

   
 

Swiftを学べるスクールで入会金は現在ならたったの3000円、サポート費用は月額500円という激安スクールです。

今後私の記事で登場するかも!?

iOSエンジニアを目指す

 
freeks :月額9800円転職の相談も載ってくれる格安プログラミングスクールです。 施設使用料はこの月額使用料さえ払っていれば使えます。 300社に及ぶ提携先企業からあなたに合う企業をご提案してくれるらしい。 日本帰ったらここに通うかもしれない。

 
:月額7800円2021/2月20日から通い始めました。 完全オンラインで、PHPを学びはじめました。 途中からの参加なのでいきなりPHPの条件分から始めています。 進度はゆっくり目なので、ついていけること間違いなし。

LINK:箕面プログラミング

 
:入会金49,800円 月会費3,980円と業界では安め。 最大の特徴は塾内限定で未経験向けの案件紹介があるとのこと。 その経験を積むだけでも本塾には所属する価値があるかもしれません。

LINK:古里塾

 
:コードペンみたいに実際にコードをっ打って勉強できます。ヒントが少ないので難しめです。無料で結構勉強できるので有難いです。

LINK:CODEPREP

 

パケットトレーサーでRIPを構築してみた。

f:id:tsuyunaruhito:20210419011105p:plain

お題「#新生活が捗る逸品」

マウスを頑なに使ってない人は、買ってみるとその動きの良さに感動することでしょう。もちろん、ショートカットキーもだいぶ覚えたでしょうから。マウスを使わなかった時代は決して無駄ではない。
ちなみに筆者が使用しているマウスは下記の通り。

Logicool G ゲーミングマウス 有線 G300Sr 左右対称 軽量 プログラムボタン9個 高精度dpi 国内正規品

新品価格
¥2,273から
(2021/4/19 01:16時点)

######################### 

どうも今日も無事日勤終わりました。

明日から月曜日と火曜日、無事何のトラブルもなく終わることを望むのみですね。

 

帰ってから少しネットワークの勉強をしていました。

ルータを起動させる際のコンフィグレーションレジスタ値が変わることで

ユーザモードかセットアップモードか、ROMMONモードか変わりますよね。

2100、2102、2142とあるのですがどれがどれやらなぜかこんがらがってしまいます。

2100か2102かたった2しか違いません。2142は42とか言う数字がついているのに。

 

2100と2102で比べていたのですが今日は違う視点から覚えることにしました。

まず、基本的な知識ですが2100と2102では起こっていることが雲泥の差ほど違います。

 

2102はまともにIOSの起動も成功しているし、別にIOSが壊れているわけでもありません。

2142はStartup-configがないか、2142を設定しているかです。

 

2100だけなんですわ、なんか信号鳴らしたり、IOSがなかったり、壊れてたり。

つまり、(2100,2102)[2142]じゃなくて、(2102,2142)[2100]だった。

 

はみごは、2100だった。

IOSがないのと、数字がなんにもないってことで覚えられました。

 ------------------------

パケットトレーサーでRIPを構築してみた。

こんにちはみんな?少なくとも私は大好きなねっとびTvのRIP構築をやってみました。

 参考の動画は以下の通りです。

 

めっちゃ簡単だった。まず、以下のように4つのルーターを準備して

それぞれIp addressを打ち込みます。もちろん、no shutdownもしました。

 

f:id:tsuyunaruhito:20190929235951p:plain

 

この時点で、show ip routeを特権モードで確認します。

Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.2.0/24 is directly connected, FastEthernet0/0

C 192.168.3.0/24 is directly connected, FastEthernet0/1

f:id:tsuyunaruhito:20190930000118p:plain

まだ二つのルートしか覚えていません。

それも当然で、RIPは有効化されていないからです。

RIPを起動するには、コマンドを四つのルーターでそれぞれ打ってやればできます。

Router(config)#router rip

Router(config-router)#network 192.168.3.0

Router(config-router)#network 192.168.2.0

Router(config-router)#

 

特権モードでshow runをすると、ripが起動したのを確認できます。

Router#show run

Building configuration...

 

Current configuration : 634 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

ip cef

no ipv6 cef

!

spanning-tree mode pvst

!

interface FastEthernet0/0

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.3.2 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

network 192.168.2.0

network 192.168.3.0

この時点で、show ip routeも打ってみると.......

R 192.168.0.0/24 [120/1] via 192.168.2.1, 00:00:12, FastEthernet0/0

R 192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:22, FastEthernet0/1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

C 192.168.3.0/24 is directly connected, FastEthernet

 

なんか出てきた。。。RはripのRですね。

pingを100回ほど送ってみました。

 

Router#ping

Protocol [ip]:

Target IP address: 192.168.0.1

Repeat count [5]: 100

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 100, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

f:id:tsuyunaruhito:20190930001641p:plain

完全に通っていますね。ご苦労サンでしたpingさん。

R 192.168.0.0/24 [120/1] via 192.168.2.1, 00:00:12, FastEthernet0/0

こちらshow ip routeの結果ですが、ネクストホップを192.168.2.1として、1ホップでいけることになっています。

 

ではこちらの経路をカットしました。

f:id:tsuyunaruhito:20190930003122p:plain

この状態でshow ip routeを打ってみる。

Gateway of last resort is not set

 

R 192.168.0.0/24 [120/2] via 192.168.3.1, 00:00:18, FastEthernet0/1

R 192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:18, FastEthernet0/1

C 192.168.3.0/24 is directly connected, FastEthernet0/1

 

今度は経路が上向きの192.168.3.1となりましたね。ホップも1増えて2になっています。

いやーやってみると結構簡単で面白かったですね。

 

以下のこともしっかり覚えられるかと思います。

show ip routeと,show runが特権モードで動くこと。

show runでripの確認ができること。

実際動かしてみるとそのプロトコルの動きだけじゃなくて周辺知識も付くのでいいですよね!

 

私は残念ながらまともに動く実機がないのでパケットトレーサーで自分を慰めているわけですが、下記のところにいけば実際の機器に触りながら講義を受けられます。

 

私は残念ながら30歳を超えているので、20万を払って受けることになってしまいますが30歳以下なら無料で受けられるそうですよ。ってもう何度も説明しているんで知っていますよね。

 

 

interier.hatenablog.com

 

 

interier.hatenablog.com

 

本サイトが参考になったらクリックをお願いします。

  にほんブログ村 にほんブログ村へ